Wednesday, December 15, 2010

Failover cluster validation test warns about PublishPTRRecordsWarn property

Coming back from a long vacation is very refreshing and it feels good to be back. I will like to share an interesting cluster validation issue encountered before leaving for vacation. The issue was encountered while running validation test with a warning in "Validate multiple subnet properties" task of failover cluster validation test.

Error verbatim : The publishPTRRecordsWarn property for network name “blah blah” is set to 1 For the current cluster configuration this value should be set to 0.

The value 1 is recommended when using DHCP and 0 when using static IP address scheme on network interface. For more information read here and here. I was using static IP address scheme on my cluster network interface and so getting warning seen below in screenshot.


Once i change the PublishPTRRecordsproperty the warning goes away as seen below. Please dont confuse yourselves by finding the PublishPTRRecordswarn property mentioned in error verbatim.


Hope this information is useful..especially if you get this error message :)  

GAURAV ANAND

5 comments:

  1. get-clusterresource is not a valid cmdlet on my cluster nodes. Where do I add/access the cluster powershell cmdlets?

    ReplyDelete
  2. here is what you need to do..might help

    http://www.windowsitpro.com/article/virtualization2/Q-Why-doesn-t-the-Get-Cluster-Windows-PowerShell-cmdlet-work-on-my-cluster-nodes-.aspx

    ReplyDelete
  3. Run Import-Module FailoverClusters at a powershell prompt on one of the nodes

    ReplyDelete
  4. Thank you Anonymous and Gaurav Anand. Worked a charm! :D

    ReplyDelete